Beer line won't connect to corny keg

Forums Brewing Equipment Beer line won't connect to corny keg

This topic contains 4 replies, has 4 voices, and was last updated by  John 10 months, 1 week ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #1325

    John
    Participant
    • Level 2 User
    • ★★

    I just kegged and pressurized a corny keg of a new IPA that I have in my keezer, but the liquid line will not attach. I have read that this can be an issue of the poppet in the post being stuck, but when I depress the poppet manually I get a nice refreshing beer shower. Even with all of the pressure released from the keg, I can’t get the line to attach. I tested it with my other kegs and it connects fine, so it is definitely an issue with the post or the poppet. Has anyone had this issue? Any idea how to resolve it without having to release the pressure and replace the post on the keg?

    thanks!

    #1359

    William
    Participant
    • Level 1 User

    If you have any keg lube rub some on the ball bearings in the connector and a bit around the gasket on the post.

    #1360

    Forest
    Participant
    • Level 1 User

    Most likely the disconnect was put back together incorrectly. Take it apart and make sure the spring is over the stem. I’ve done it where the spring is to the side and the stem gets jammed.

    #1361

    Katrina
    Participant
    • Level 1 User

    Or did you switch posts the last time you cleaned the keg? They are different. It is also possible the disconnect is worn out, it happens.

    #1362

    John
    Participant
    • Level 2 User
    • ★★

    I think I must have switched the posts when I cleaned it, because I switched them back and everything is working fine now. Such a simple mistake!

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.